
Best Practices For Using the FRC cRIO Project Frameworks 

Here we will discuss the concept of a framework, and walk through the functionality contained in the 

two robot frameworks supplied with LabVIEW FRC 
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What is a framework? 

A programming framework is piece of default code that provides the overall structure, or architecture, 

of your program. It defines interaction between different code sections, and provides designated places 

to insert specific functionality.  

The frameworks are supplied as a starting point; they let you focus on actual functionality in the limited 

time available to you, rather than program architecture.  

When you open up LabVIEW FRC Edition you will see a link to the FRC cRIO Robot Project. 



 

To create a new project, just left click on FRC cRIO Robot Project to bring up the Create New FRC Robot 

Project window. 



 

In this window you can chose the basic or advanced framework, name your new project, choose where 

the project will be save, and configure your cRIO IP address.  You will replace xx.yy with your team 

number.  I.e. if you’re team #1 you would replace xx.yy with 00.01; if you were team #1000 then you 

would replace it with 10.00.  You’ll find that that basic and advanced framework’s are very similar, but 

for now we will explore the basic framework. 

The Basic Framework 

Once you click finish in the Create New Project Window you will see the FRC cRIO Robot Project Explorer 

window. 



 

This window is like a table of contents for you program.  The VIs listed below your RT CompactRIO 

Target will be deployed to your cRIO FRC when you run your code.  

Basic Robot Main:  This is the main VI, the other VIs are actually called inside of this VI as sub VIs.  We 

will explore this VI in detail later. 

Basic Robot Global:  This VI holds information about the various motors, sensors, and other tasks you 

have configured. 

Autonomous Independent:  This VI is what will run when your robot is in autonomous mode—In the 

basic framework this VI is automatically started and stopped when your robot is set to autonomous 

mode. 

Error Display:  You can use this VI to display any errors that occur in your program. 

The best place to start is by looking at the Basic Robot Main VI.  The front panel is pretty empty since 

you’ll be using the Dashboard to view the data from your robot.  The important part of this VI is the 

Block Diagram. 



 

There are five major sections of code that run in parallel in this framework so we’ll take a minute to 

explore each. 

1. Enable data publishing back to the dashboard:  This section of code determines which 
of your modules will pass data back to the dashboard.  You can use the constant to the 
left of the UpdateDashboard VI to select the channels you want to monitor—choose 
true to monitor a particular channel and false if you do not want to monitor it.  By 
default only the first analog, first digital and solenoid channels are selected.  You will 
probably want to change which channels you monitor on the dashboard to troubleshoot 
while building your robot. 

 

2. Start Robot Communications:  This VI opens communication between the cRIO and 
driver station and regularly checks for information from the host computer, joystick and 
driver station in addition to initializing the system watchdog on the cRIO.  This VI is 
necessary for the cRIO and driver station to communicate properly.  You will probably 
not want to modify this sub-VI. 

 

3. Update Motors and I/O Based Upon Communications:  In this framework, this section 
of the VI is responsible for controlling how your robot behaves in both TeleOp (joystick) 
mode and autonomous mode.  By default, while in TeleOp mode, this framework will 
configure a 2 wheel robot and use the joystick inputs to control the motors.  This VI 
checks the Competition Mode each iteration and will run the Autonomous Independent 
VI during autonomous mode by calling a reference to it.  There are two default cases in 



the Autonomous Independent VI; the absolute default (false case) is to do nothing at all.  
However, if you open the block diagram to this VI you can enable the true case of the 
case structure.  If you enable this case then the robot will move forward and backwards 
4 times and then stop.  You will likely want to modify this sub VI to choose the 
autonomous behavior of your robot. 

 

 
4. Process Camera Images:  This section of code is designed to let you choose if and when 

to read and process images from your camera.  The code to the left of the loop opens a 
connection to your camera and then the loop will read in an image if you have the 
Enable Vision control set to true.  Image processing is a computationally intensive 
operation so it’s important to this is in a separate parallel loop.  For example, we may be 
able to run the TeleOp loop 100 times a second which gives you responsive control of 
your robot.  However, you may only be able to process 10 images a second.  If we did 
our image processing in the same loop as out TeleOp control then both process would 
be limited to the slower rate of 10 cycles per second.  This would significantly reduce 
your ability to control the robot.  However, by putting different processes in separate 
loops we are able to run each loop at a different rage. 

 

5. Template loop for time based operations:  This loop is here to indicate where you could 
begin to add in other time based operations such as sensor measurements.  This would 
be an ideal place to implement a sensor control loop.  You could put multiple processes 



at the same rate in this loop or add additional loops to run additional processes at 
different rates. 

 

Now that we’ve covered the basic framework we will go ahead and take a look at the advanced 

framework.  We will focus on how these two frameworks are similar as well as the key concepts 

necessary for adapting to the advanced framework. 

The Advanced Framework  

We’ve already seen that you can open the advanced framework from the LabVIEW Getting Started 

window, but there is another way to open a new project.  You can navigate to File» New from either the 

getting started window or another VI to bring up the New window.  To open the project wizard, navigate 

to Project» Project From Wizard»FRC cRIO Robot Project.  This will open the Create New FRC Robot 

Project window that we saw earlier; this time choose the Advanced Framework and click Finish. 

 



You can already see a couple of differences in the advanced framework Project Explorer Window.  First 

of all, there is another section called Type Definitions (Type Def), which replaces the functionality of the 

Basic Robot Global VI.  We’ll talk about Type Defs. more in a later section.  Secondly, there are only two 

other VIs, Robot Main and Error Displays.  In this framework the Autonomous Independent code should 

be placed inside the Robot Main rather than a separate VI. 

 

Once again we’ll begin by looking at the block diagram of the Robot Main.VI. 



 

This framework implements Type Definitions and sub VIs to maintain a more concise block diagram.  

Like the basic framework, this VI has 5 main sections, each section serves the same purpose as in the 

basic framework but they are implemented in different ways.  Rather than restating what each section 

of code does, we’ll focus on the differences between the two frameworks. 

1. Begin VI:  You may have noticed that in the basic framework each session to a motor, 
sensor, camera, or watchdog timer had to be initialized to the left of the loop where it 
was used.  The advanced framework combines all of these initialization VIs into a single 
sub VI to clean up the main VIs block diagram.  You will need to open this VI to configure 
all of your tasks just like the block diagram constants in the basic framework. 

 

2. TeleOp and Autonomous Modes:  This section of code uses a state machine which 
consists of a case structure inside of a loop.  Each time the loop runs the Get 
Competition Mode VI will check the current mode and then run the appropriate case 
from the case structure.  The major difference between this structure and the basic 
framework is that both the Tele-op and Autonomous code are in sub-VIs. 



 

3. Remaining four VIs:  The remaining four VIs serve the same purpose as the other 4 
sections of the basic framework.  The Start Robot Communication and Start Dashboard 
VIs are identical, and the Acquire/Process Images Loop and Periodic Task Loop have 
been put into sub VIs. 

 

Both the Basic and Advanced Frameworks provide for exceptional organization of your code, however 

the advanced framework allows your code to be even more modular.  The cost of cleaning up this code 

is learning slightly more advanced topics: Editing sub VIs, Editing Type Definitions, and Using Global 

Variables.  We will start with the basic framework and go through how you would implement an 

accelerometer read and then do the same thing using the advanced framework. 

Adding the Accelerometer Example to the Basic Framework Using Local Variables 

The great thing about programming is that you can reuse code over and over again.  Rather than adding 

an accelerometer read from scratch we will reuse the example program code to implement this much 

faster.  From the Getting Started Window Click on Examples in the bottom right.  When the Select an 

Example to Open window appears, choose the Accelerometer Alarm Example and click OK.  Then open 

the Basic Framework by navigating to File» New to open the New window.  Go to Project» Project From 

Wizard» FRC cRIO Robot Project and click OK; follow the wizard to enter your team number as the IP 

Address and finish the Wizard.  At this point you should have both the example and framework Project 

Explorer Windows Open. 



 

Next we want to open up both the Accelerometer Alarm Example VI and the Basic Robot Main VIs side-

by-side so that we can copy the example into the framework.  Copy and paste the entire Accelerometer 

example into the Main VI using Edit» Copy and Edit» Paste.  Make some room at the bottom of the 

robot main VI so that we can clean up the example and integrate it into the framework.  Here’s the 

example we start with.

 

The great thing about this framework is that you only have to delete two VIs to run the framework after 

pasting in this example.  The Driver station Start and Stop Communication VIs are not necessary because 

the framework handles this for you at the top—these should be removed from the pasted code.  After 



doing this you can already run your framework with the newly implemented example VI and it will act as 

a second Time Based Operations loop running every 20 ms.    

These examples are great starting places for setting up your sensors, but there are a number of 

elements in this example that are unnecessary when implementing them into the framework.  I’ll list a 

number of possible modifications as well as an explanation of why you may want to make these 

changes. 

1. Change Controls to Constants:  While you’re actually running the framework and 
controlling your robot with the driver station you will not be able to change the values 
of control.  You should use example programs to test and calibrate your sensors and 
then set these values using constants in your framework.  To make this change just right 
click on these constants and select Change to Constant. 

2. Remove unnecessary controls and indicators:  Again, while running the framework you 
will not be viewing the front panel indicators.  In order to have more efficient code you 
should eliminate unnecessary indicators.  In the case of this alarm example it would 
probably be helpful to know the value of the Acc Value and In Alarm indicators in your 
control loop, but you probably don’t need the Accelerometer Chart.  You can select and 
delete indicators you don’t need.  The Stop button can also be removed since you won’t 
be using the front panel during robot control. 

3. Modify the Comments:  The comments in the Example Programs are very detailed and 
intended for informing new users of their operations.  To keep your Main VI Block 
Diagram clean and organized you may want to shorten these comments down.  Note:  
While it may seem easiest to just delete these comments all together to make space, I 
would not recommend doing so.  Documenting your code is extremely important 
because it can save you hours of time in the long run.  You may remember what this 
section of code is doing now, but if you come back to it weeks later you may not.  I like 
to make my comments just long enough so that I can read a few words and know 
exactly what the code is doing. 

4. Add in Custom Analysis:  This example program is just that, an example.  While this VI 
was built to perform a limit test on the accelerometer data, there are many, many more 
possible use cases for this data so feel free to delete the limit test and add in any 
custom analysis that you want! 

 

After making the above modifications my new code looks like this. 



 

 

At this point your framework will run and update the Acc Value and In Alarm indicators on your front 

panel every 20 ms.  This is great if you’re just interested in seeing these values, but since you’re likely 

interested in using this data to control a robot, we need a way to read this data in the Update Motors 

and I/O based upon communications loop. 

In order to pass data between two loops within the same VI, we will use a Local Variable.  A Local 

Variable is a reference to a control or indicator.  A Local Variable can either be used to read the current 

value or write a new value to the control or indicator.  In this case we want to create a Local Variable to 

read the current value of the Acc Value and In Alarm indicators in the motor control loop.  To create a 

local variable, just right click on the control or indicator of interest and choose Create» Local Variable. 

 

By default Local Variables are created to write a new value.  In this case since we want to read the value 

just right click the variable and choose Change to Read. 



 

This Local Variable can be placed anywhere you want inside of the same VI to access the current value of 

the Acc Value Indicator.  Local Variables should be used sparingly because they make code more difficult 

to follow, but passing data between loops in the same VI is an acceptable use case.  If you need to pass 

data between multiple loops in different VI you can use Global Variables (discussed in the next section). 

Global variables are ideal for use with the advanced framework since the parallel loops are in different 

sub VIs. 

Note:  As a general rule of thumb you can have multiple Reads from your Variables, but you should 

only write to a variable one place in your code.  If you write to the variable in multiple places then it 

becomes difficult to know which value you will read due to race conditions. 

Adding the Accelerometer Example to the Advanced Framework Using Type Definitions and Global 

Variables 

The first step in adding a new sensor to the advanced framework is to decide which loop you want to 

acquire this data in.  As mentioned earlier it is important to keep some tasks separate, i.e. motor control 

and image processing since both task will be limited the slower rate if they are in the same loop.  If we 

want to acquire data from an accelerometer every 100 ms then we should use the periodic tasks VI. 

Once you decide which loop you want to add your new sensor to then you need to initialize the sensor 

in the Begin VI.  To open of the block diagram of the Begin VI double click on its icon and then switch to 

the block diagram.  Scroll to the bottom of the block diagram and you’ll see the section of code that 

outputs information to the Periodic Task Data output of the Begin VI.  We need to make sure we add the 

Accelerometer Device Reference to this cluster so that we can access it in the Periodic Tasks VI. 



 

 

You will need to add an Open Accelerometer VI and configure it as in the Getting Started With Sensors 

Tutorial. 

 

Once you’ve configured the Open VI we need to modify the Periodic Task Data Type Definition so that 

we can pass the data from the Begin VI to the Periodic Tasks VI using a single wire.  The first step is to 

right click the AccelerometerDevRef terminal and select Create» Indicator. 

 

Once you create the AccelerometerDevRef indicator double left click on it to find the indicator on 

the front panel.  Once you find the indicator on the front panel, left click on its boarder and select 

Edit» Copy from the menu bar and then switch back to the block diagram. 



 

The next step is to paste this indicator into the Periodic Task Data Type Definition.  Right click on the 

Periodic Task Data and select Open Type Def. 



 

This will open the Type Definition for this indicator as shown below: 



 

 A type definition is a lot like a normal control or indicator, but creating a type definition allows you to 

create custom controls and indicators that can contain multiple controls that you can use over and over 

again.  The biggest benefit of Type Definitions is that by changing the Type Definition file you can 

automatically update all of the copies at one time—it will update all controls, indicators and constants 

that reference that Type Definition.  We will see this in just a minute when we save and close this file.  

The Periodic Task Data constant in the Begin VI and the Periodic Task Data Control in the Periodic Tasks 

VI will both update automatically.  This can save you a lot of time in modifying your code and also keeps 

the task data organized. 

This particular Type Definition already has a number of elements, but space has been provided at the 

bottom to add more.  Scroll down to the bottom of the front panel and expand the cluster frame to 

make room for the AccelerometerDevRef.  After you have made some room go to Edit» Paste to put a 

copy of the AccelerometerDevRef on the front panel and then drag it inside of the frame. 



 

Now just save and close the Type Definition (File» Save) and go back to the Begin VI.  Note:  You must 

close the Type Def. before it will update all the copies in your project.  Once you’re back to the Begin 

VI’s block diagram there are a couple things to notice.  First we’ll expand the Bundle By Name VI to have 

three inputs by hovering over the bottom edge and left clicking.  Notice that the third element 

automatically populates with AccelerometerDevRef.  If your third element does not update then make 

sure that you’re Type Def. file has been saved and closed.  If the Type Def. wasn’t closed before (and is 

now) just left click on the third slot and select AccelerometerDevRef from the drop down menu.  If you 

see AccelerometerDevRef here then that means you’ve successfully updated the Type Def. 

 

In addition to modifying this Periodic Task Data Indicator, you have also updated the constant to the left 

that feeds into the bottom of the Bundle By Name VI.  This constant was updated because it is another 

copy of the same Type Def. 



 

To finish modifying the Begin VI, delete the AccelerometerDevRef control that we copied earlier and 

connect the AccelerometerDevRef output of the Open Accelerometer VI to the third slot of the Bundle 

By Name VI.  Once this is done you can save and close the Begin VI. 

 



At this point you are ready to add a Read Accelerometer VI inside the Periodic Tasks VI.  This is an 

excellent opportunity to take advantage of the example code that installs with LabVIEW FRC.  To access 

the accelerometer example go to View» Getting Started Window and then click on Examples in the 

bottom right of the Getting Started Window to display the Select an Example to Open Window.  Select 

Accelerometer Alarm Example and click OK. 

 

Open the Accelerometer Alarm Example VI from the project window by double clicking. 



 

Open the block diagram of the Accelerometer Alarm Example and the Periodic Tasks VI.  We want to 

copy and paste the code inside the example’s loop into the Periodic Tasks VI.  Inside of the periodic tasks 

VI we want to read the accelerometer value so we need at least a Get Acceleration VI in the second 

loop.  For demonstration purposes we will go ahead and assume we want to implement the limit test as 

shown in the example VI.  In that case you should copy and paste everything except for the wait from 

the Acceleration Alarm Example into the Periodic Tasks VI.  To do this left click and lasso everything 

inside the Acceleration Alarm Example loop and Select Edit» Copy.  Then go to the Periodic Tasks VI and 

paste the code into an empty space on the block diagram using Edit» Paste. 



 

When we implement this code into the periodic tasks loop we will not need all of the features.  Since we 

won’t be viewing the front panel while operating the robot, we need to change the controls for the 

center voltage, gain (VoltsPerG), Upper Alarm Bound and Lower Alarm Bound to constants.  We can also 

remove the Stop button since we only want this loop to stop if there is an error with the Accelerometer 

task.  We also do not need to use the Accelerometer Chart because we won’t be viewing this data during 

robot operation.  The two values of interest would be the Acc Value and In Alarm indicators.  These two 

values may produce useful information that we would want to use in the main TeleOp and/or 

autonomous modes loop.  After we clean up the code we will go through how to pass information 

between the two loops. 

Clean Up Steps: 

1. Press Ctrl+B to remove all broken wires. 
2. Select and delete the Comments, Wait VI and constant, Accelerometer Chart, Boolean 

Logic Or VI, and the Stop Button.  
3. Right Click on the Center Voltage Control and select Change to Constant.  Do this for the 

other 3 controls. 
4. Re-arrange the remaining VIs. 

 

This segment of code is ready to be pasted into the periodic task 100 ms loop.  Once you drag this code 

into the loop use an Unbundle by Name VI to pass the AccelerometerDevRef to the SetCenterVoltage VI.  

You should also connect the output of the Status to the Conditional Terminal and add a Close VI outside 

the loop to close the task after execution stops. 



 

At this point you have completed the necessary code to read the accelerometer value ever 100 ms.  

However, if you want to use this data to affect your motor control or autonomous VI then you will need 

to pass the Acc Value and In Alarm values to the other loop.  In order to pass data between this sub-VI 

and the main VI you will need to use a global variable.  A Global variable is a link to a memory location 

that stores data so that all VIs within one project have access to the value.  To create a global follow 

these steps. 

1.  Add a Global Variable to your block diagram from the functions pallet.  It is located in 
Functions» Structures» Global Variable. 

2. Double left click the Global Variable to open the front panel. 
3. Add a Numeric Control to the front panel and rename it Acc Value. 
4. Save and close the Global Variable. 
5. Left click the global you added and select acc value from the drop down to link this 

global to the variable you just made. 
6. Connect the Acceleration Output of the Get Acceleration VI to the Global Variable and 

then delete the original Acc Value Indicator. 
7. Repeat the same steps for the In Alarm indicator—in step 3 add a Boolean indicator 

instead of a Numeric Control because the data type of the Global Variables needs to 
match the indicator. 



 

This is the last necessary modification to the Periodic Tasks VI so you can Save and Close it to return to 

the FRC cRIO Robot Project Window.  Now you will see the two global variables you just created in the 

Project window: 



 

Any time that you want to access the current value of either of these variables in your project you can 

just drag and drop these variables onto other block diagrams.  This is a great way to read the current 

acceleration value in your main loop so that you can use this information to control the robot.   

Note:  As a general rule of thumb you can have multiple Reads from your Global Variables, but you 

should only write to a global variable one place in your code.  If you write to the variable in multiple 

places then it becomes difficult to know which value you will read due to race conditions.  When you 

drag and drop a Global Variable it will be a Write instance by default, to change this right click and 

select Change to Read. 



 

 

Conclusion 

Congratulations! You now know how the default robot frameworks are structured. Whether you choose 

to use the Basic or the Advanced framework you can effectively use and customize these programming 

structures.  If you have additional questions about using these frameworks please post comments so we 

can fill in as needed. 


